[Home] [Downloads] [Search] [Help/forum]

Gammon Software Solutions forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  MUSHclient
. -> [Folder]  Bug reports
. . -> [Subject]  Crash on Startup
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?
(New message)
Subject: Crash on Startup
Name:
Your forum user name.
Register forum user name
Password:
Your forum password.
Forgotten password?
Message:
Message to be posted (in English, please)
Maximum of 6000 characters. Text only please, no HTML.
Forum codes:
Check this if your message uses 'forum codes' or templates (auto-detected for new posts).
Forum codes Templates

Save this message ...


Subject review (reverse sequence)

Pages: 1 2  

Posted by Nick Gammon   Australia  (19,363 posts)  [Biography] bio   Forum Administrator
Date Fri 27 Jan 2012 04:05 AM (UTC)  quote  ]
Message

** Triggers: 564 in world file, triggers enabled: yes. [Triggers]


Maybe one of those triggers is responsible. You can copy and paste triggers from one world to another. Maybe if you do that in batches and test, then if it crashes you will know it was something in the last batch.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by MPT   (2 posts)  [Biography] bio
Date Fri 27 Jan 2012 02:02 AM (UTC)  quote  ]
Message
Nick Gammon said:

Jadinna said:

Okay, the crashes have still been happening. ...


Try making a new world, totally without any triggers or extras, and connecting. Let us know if that crashes or not.


Someone in my game forums told me to do that, too. I did, and it worked. I didn't even realize you could make two worlds for the same game. Here's the summary on the original world that was having problems, though.:

-------------- MUSHclient summary --------------

MUSHclient version: 4.73
Compiled: May  8 2011.
Time now: Thursday, January 26, 2012, 8:51 PM
Operating system: Windows 7
Libraries: Lua 5.1.4, PCRE 8.10, PNG 1.5.2, SQLite3 3.7.6.2, Zlib 1.2.5
World name: 'Shattered Kingdoms', ID: 49d62cb84999b434340c54b9
-- Scripting --
Script language: Lua, enabled: yes
Scripting active: yes
Lua sandbox is 127 characters, DLL loading allowed: yes
Scripting prefix: ''. External editor in use: NO.
Scripting for: 0.000068 seconds.
-- Triggers, aliases, timers, variables --
** Triggers: 564 in world file, triggers enabled: yes. [Triggers]
   564 enabled, 0 regexp, 15792 attempts, 0 matched, 0.069597 seconds.
** Aliases: 11 in world file, aliases enabled: yes. [Aliases]
   11 enabled, 0 regexp, 0 attempts, 0 matched, 0.000000 seconds.
** Timers: 0 in world file, timers enabled: yes.
   0 enabled, 0 fired.
   Timers checked every 0.1 seconds.
** Variables: 0.
-- MCCP --
MCCP not active.
-- Plugins (Processing order) --
** Plugins: 0 loaded, 0 enabled.
-- Comms --
Connect phase: 8 (Open). NAWS wanted: NO
Received: 1887 bytes (1 Kb)
Sent: 0 bytes (0 Kb)
Received 2 packets, sent 0 packets.
Total lines received: 74
This connection: Sent 0 lines, received 64 lines.
Telnet (IAC) received: DO: 0, DONT: 0, WILL: 0, WONT: 0, SB: 0
-- MXP --
MXP active: NO, Pueblo mode: NO, Activated: On command
MXP tags received: 0
MXP entities received: 0
MXP errors: 0
-- Commands --
Commands in command history: 0
Speed walking enabled: NO. Speed walking prefix: #
Command stacking enabled: NO. Command stack character: ';'
Accelerators defined: 0
-- Miniwindows --
** Miniwindows: 0 loaded, 0 shown.
-- Output window --
Output pixels: width 747, height: 528, font width: 8, font height: 15
               can show 93 characters, wrapping at column 80, height 35 lines.
Output buffer: 92 of 5000 lines.
-- Miscellaneous --
Logging: NO, tracing: NO
** SQLite3 databases: 0
Sound buffers in use: 0
[Go to top] top

Posted by Nick Gammon   Australia  (19,363 posts)  [Biography] bio   Forum Administrator
Date Sun 22 Jan 2012 06:47 PM (UTC)  quote  ]
Message
Jadinna said:

Okay, the crashes have still been happening. ...


Try making a new world, totally without any triggers or extras, and connecting. Let us know if that crashes or not.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Nick Gammon   Australia  (19,363 posts)  [Biography] bio   Forum Administrator
Date Sun 22 Jan 2012 06:44 PM (UTC)  quote  ]
Message
It was for MPT who said s/he was having the same problems.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Jadinna   Australia  (8 posts)  [Biography] bio
Date Sun 22 Jan 2012 01:45 PM (UTC)  quote  ]

Amended on Sun 22 Jan 2012 01:46 PM (UTC) by Jadinna

Message
Nick Gammon said:

(summary)


I'm not sure who this is for.. I supplied my Summary in my latest post using the 'Immediate window'.
[Go to top] top

Posted by Nick Gammon   Australia  (19,363 posts)  [Biography] bio   Forum Administrator
Date Sun 22 Jan 2012 07:34 AM (UTC)  quote  ]
Message
Template:bug

Please provide a summary of your world configuration:

  • Either use the scripting Immediate window (Ctrl+I) to execute: Debug ("summary")

    or

  • Install the Summary plugin (see "Summary" feature) and type "summary"

Then copy the resulting information from the output window, and paste into a Forum message.

You need version 4.55 onwards of MUSHclient to do this.


- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by MPT   (2 posts)  [Biography] bio
Date Sun 22 Jan 2012 06:04 AM (UTC)  quote  ]
Message
I've been experiencing this problem, too. I'm seriously code illiterate though, and have no idea how to identify the problem, much less solve it. I do have quite a few triggers set up, but they're fairly common ones for the mud I play (Shattered Kingdoms.)

I'm trying to get some feedback on the game's Client forums, and to be honest I don't have anything helpful to contribute here yet.. But just know that you are not alone, at least! :/
[Go to top] top

Posted by Jadinna   Australia  (8 posts)  [Biography] bio
Date Mon 16 Jan 2012 07:30 AM (UTC)  quote  ]
Message
Okay, the crashes have still been happening.

Auto World Login at Startup has been turned off
I still have autolog turned on (incase that is an issue)

With the below error message:


Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	MUSHclient.exe
  Application Version:	4.0.81.0
  Application Timestamp:	4f022d0a
  Fault Module Name:	MUSHclient.exe
  Fault Module Version:	4.0.81.0
  Fault Module Timestamp:	4f022d0a
  Exception Code:	c0000005
  Exception Offset:	0005504d
  OS Version:	6.1.7601.2.1.0.256.48
  Locale ID:	3081
  Additional Information 1:	f2e0
  Additional Information 2:	f2e0538414a1a64cd792a0c0c11b374a
  Additional Information 3:	85cb
  Additional Information 4:	85cb3e32f249ce7ef70480cc79e53d12

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt


The Debug("summary") is:

-------------- MUSHclient summary --------------

MUSHclient version: 4.81
Compiled: Jan  3 2012.
Time now: Monday, January 16, 2012, 4:25 PM
Client running for:  0d 00h 00m 22s
World opened for:    0d 00h 00m 21s
Operating system: Windows 7
Libraries: Lua 5.1.4, PCRE 8.21, PNG 1.5.7, SQLite3 3.7.9, Zlib 1.2.5
World name: 'HM.Jazz', ID: d2cde7acbb92e825f33ae807
-- Scripting --
Script language: Lua, enabled: yes
Scripting active: yes
Lua sandbox is 125 characters, DLL loading allowed: yes
Scripting prefix: ''. External editor in use: NO.
Scripting for: 0.000369 seconds.
-- Triggers, aliases, timers, variables --
** Triggers: 9 in world file, triggers enabled: yes. [Triggers]
   9 enabled, 9 regexp, 0 attempts, 0 matched, 0.000000 seconds.
** Aliases: 0 in world file, aliases enabled: yes.
   0 enabled, 0 regexp, 0 attempts, 0 matched, 0.000000 seconds.
** Timers: 0 in world file, timers enabled: yes.
   0 enabled, 0 fired.
   Timers checked every 0.1 seconds.
** Variables: 0.
-- MCCP --
MCCP not active.
-- Plugins (Processing order) --
** Plugins: 0 loaded, 0 enabled.
-- Comms --
Connect phase: 0 (Closed). NAWS wanted: yes
Received: 0 bytes (0 Kb)
Sent: 0 bytes (0 Kb)
Received 0 packets, sent 0 packets.
Total lines received: 46
This connection: Sent 0 lines, received 46 lines.
Telnet (IAC) received: DO: 0, DONT: 0, WILL: 0, WONT: 0, SB: 0
-- MXP --
MXP active: NO, Pueblo mode: NO, Activated: On command
MXP tags received: 0
MXP entities received: 0
MXP errors: 0
-- Commands --
Commands in command history: 0
Speed walking enabled: NO. Speed walking prefix: #
Command stacking enabled: NO. Command stack character: ';'
Accelerators defined: 0
-- Miniwindows --
** Miniwindows: 0 loaded, 0 shown.
-- Output window --
Output pixels: width 1659, height: 837, font width: 11, font height: 20
               can show 150 characters, wrapping at column 150, height 41 lines.
Output buffer: 64 of 500000 lines.
-- Miscellaneous --
Logging: NO, tracing: NO
** SQLite3 databases: 0
Sound buffers in use: 0

---------------------- End summary ----------------------


Incase, here is a list of my triggers:

------ Trigger List (evaluation order) ------

  1. Regexp,  Enabled : IncomingPages  ^(From afar,|.* pages(?=:)|\(To: .*\))
  2. Regexp,  Enabled : OutgoingPages  ^(Long distance to .*(?=:)|You paged .[^']* with(?= '*))
  3. Regexp,  Enabled : DoubleQuotes   (\B)(\".[^"]*\")(\B)
  4. Regexp,  Enabled : SingleQuotes   (\B)(\'.[^']*\')(\B)
  5. Regexp,  Enabled : CotC           \b(Name1|Name2|Name3|Name4|Name5|Name6||Name7|Name8|Name9|Name10|Name11|Name12)('s){0,1}\b
  6. Regexp,  Enabled : Self           \b(MyName1|MyName2|MyName3|MyName4|MyName5)('s){0,1}(?=\b)
  7. Regexp,  Enabled : TalonsofCorvus \b(Name1|Name2|Name3|Name4|Name5|Name6|Name7|Name8|Name9|Name10|Name11)('s){0,1}\b
  8. Regexp,  Enabled : BBoards        ^<+bb> New message .*
  9. Regexp,  Enabled : Mail           ^Mail: .*
9 triggers.
[Go to top] top

Posted by Nick Gammon   Australia  (19,363 posts)  [Biography] bio   Forum Administrator
Date Wed 21 Dec 2011 08:46 PM (UTC)  quote  ]
Message
Jadinna said:

The crashing has seemed to stop now that I have auto connect turned off. I have re-added all my plugins, and still no crashes.


I would try removing that plugin, turning auto-connect back on, and trying again. If it crashes then, the plugin might be trying to access something that isn't available quite yet.

As I recall, there are a few "race" conditions at startup. Things have to be done in a certain order, eg. A before B. If something expects B to be done first then it might cause problems. And if you change it to B before A, then other problems arise.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Fiendish   USA  (985 posts)  [Biography] bio   Global Moderator
Date Wed 21 Dec 2011 05:44 PM (UTC)  quote  ]
Message
There have been, in the past, problems with doing things right as MUSHclient was trying to start up. Perhaps if you post the exported contents of all your triggers and plugins we can help you narrow it down.

http://aardwolfclientpackage.googlecode.com/
https://github.com/fiendish/aardwolfclientpackage
[Go to top] top

Posted by Jadinna   Australia  (8 posts)  [Biography] bio
Date Wed 21 Dec 2011 05:40 PM (UTC)  quote  ]
Message
The crashing has seemed to stop now that I have auto connect turned off. I have re-added all my plugins, and still no crashes.

I was wondering if it may have been something to do with starting up MUSHclient and automatically starting a world and initiating logging that might have something to do with it?

Let me do some fiddling around to see if I can get something a little more definitive.
[Go to top] top

Posted by Fiendish   USA  (985 posts)  [Biography] bio   Global Moderator
Date Wed 21 Dec 2011 05:34 PM (UTC)  quote  ]
Message
Also, if the crash goes away when you disable that plugin, please post the contents of the plugin somewhere so we can see where the problem is.

http://aardwolfclientpackage.googlecode.com/
https://github.com/fiendish/aardwolfclientpackage
[Go to top] top

Posted by Nick Gammon   Australia  (19,363 posts)  [Biography] bio   Forum Administrator
Date Tue 20 Dec 2011 08:25 PM (UTC)  quote  ]
Message
I am not familiar with the DailyLog plugin. Try removing that and then connecting.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Jadinna   Australia  (8 posts)  [Biography] bio
Date Tue 20 Dec 2011 02:56 PM (UTC)  quote  ]
Message

-------------- MUSHclient summary --------------

MUSHclient version: 4.80
Compiled: Dec 10 2011.
Time now: Tuesday, December 20, 2011, 11:55 PM
Client running for:  0d 00h 00m 08s
World opened for:    0d 00h 00m 08s
Operating system: Windows 7
Libraries: Lua 5.1.4, PCRE 8.13, PNG 1.5.5, SQLite3 3.7.8, Zlib 1.2.5
World name: 'HM.Jazz', ID: d2cde7acbb92e825f33ae807
-- Scripting --
Script language: Lua, enabled: yes
Scripting active: yes
Lua sandbox is 125 characters, DLL loading allowed: yes
Scripting prefix: ''. External editor in use: NO.
Scripting for: 0.000070 seconds.
-- Triggers, aliases, timers, variables --
** Triggers: 10 in world file, triggers enabled: yes. [Triggers]
   10 enabled, 10 regexp, 0 attempts, 0 matched, 0.000000 seconds.
** Aliases: 0 in world file, aliases enabled: yes.
   0 enabled, 0 regexp, 0 attempts, 0 matched, 0.000000 seconds.
** Timers: 0 in world file, timers enabled: yes.
   0 enabled, 0 fired.
   Timers checked every 0.1 seconds.
** Variables: 0.
-- MCCP --
MCCP not active.
-- Plugins (Processing order) --
ID: 36ef58963eb1bbfb9cb38bf8, 'DailyLog', (Jscript, 0.000 s) Enabled [Al Ti]
** Plugins: 1 loaded, 1 enabled.
-- Comms --
Connect phase: 0 (Closed). NAWS wanted: yes
Received: 0 bytes (0 Kb)
Sent: 0 bytes (0 Kb)
Received 0 packets, sent 0 packets.
Total lines received: 47
This connection: Sent 0 lines, received 47 lines.
Telnet (IAC) received: DO: 0, DONT: 0, WILL: 0, WONT: 0, SB: 0
-- MXP --
MXP active: NO, Pueblo mode: NO, Activated: On command
MXP tags received: 0
MXP entities received: 0
MXP errors: 0
-- Commands --
Commands in command history: 0
Speed walking enabled: NO. Speed walking prefix: #
Command stacking enabled: NO. Command stack character: ';'
Accelerators defined: 0
-- Miniwindows --
** Miniwindows: 0 loaded, 0 shown.
-- Output window --
Output pixels: width 1659, height: 827, font width: 11, font height: 20
               can show 150 characters, wrapping at column 150, height 41 lines.
Output buffer: 65 of 500000 lines.
-- Miscellaneous --
Logging: NO, tracing: NO
** SQLite3 databases: 0
Sound buffers in use: 0

---------------------- End summary ----------------------
[Go to top] top

Posted by Nick Gammon   Australia  (19,363 posts)  [Biography] bio   Forum Administrator
Date Tue 20 Dec 2011 04:31 AM (UTC)  quote  ]
Message
Please turn auto connect off, so you can open without connecting. Then:

Template:bug

Please provide a summary of your world configuration:

  • Either use the scripting Immediate window (Ctrl+I) to execute: Debug ("summary")

    or

  • Install the Summary plugin (see "Summary" feature) and type "summary"

Then copy the resulting information from the output window, and paste into a Forum message.

You need version 4.55 onwards of MUSHclient to do this.


- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


3,526 views.

This is page 1, subject is 2 pages long: 1 2  [Next page]

[New subject]  Start a new subject   [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

[Home]

Written by Nick Gammon - 5K

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( http://www.gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Internet Contents Rating Association (ICRA) - 2K]    [Web site powered by FutureQuest.Net]