[Home] [Downloads] [Search] [Help/forum]

Gammon Software Solutions forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  SMAUG
. -> [Folder]  Running the server
. . -> [Subject]  Fuss19 - Mud Loads but nothing works
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

Fuss19 - Mud Loads but nothing works

[Reply to this subject]  Reply to this subject   [New subject]  Start a new subject   [Refresh] Refresh page


Posted by Nargsbrood   (54 posts)  [Biography] bio
Date Sun 03 Jul 2011 08:29 AM (UTC)  quote  ]
Message
I am running on cygwin with windows 7 home premium 64bit.

When attempting to run smaug.exe, it displays the below errors (and many more for each command) and then all areas fail to load. connecting to mud allows me to create character but when in game no commands work other than socials.

Any ideas? TIA

Nargs



$ ../src/smaug.exe
Sun Jul 3 01:00:23 2011 :: Booting Database
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
Sun Jul 3 01:00:23 2011 :: [*****] BOOT: ---------------------[ Boot Log ]----- ---------------
Sun Jul 3 01:00:23 2011 :: Initializing libdl support...
Sun Jul 3 01:00:23 2011 :: Loading commands...
Sun Jul 3 01:00:23 2011 :: [*****] BUG: Error locating do_say in symbol table. No error
Sun Jul 3 01:00:23 2011 :: [*****] BUG: fread_command: Function do_say not foun d for '
Sun Jul 3 01:00:23 2011 :: [*****] BUG: Error locating do_emote in symbol table . No error
Sun Jul 3 01:00:23 2011 :: [*****] BUG: fread_command: Function do_emote not fo und for ,
Sun Jul 3 01:00:23 2011 :: [*****] BUG: Error locating do_chat in symbol table. No error
Sun Jul 3 01:00:23 2011 :: [*****] BUG: fread_command: Function do_chat not fou nd for .
Sun Jul 3 01:00:23 2011 :: [*****] BUG: Error locating do_immtalk in symbol tab le. No error
[Go to top] top

Posted by Zeno   USA  (2,871 posts)  [Biography] bio   Moderator
Date Reply #1 on Sun 03 Jul 2011 04:27 PM (UTC)  quote  ]
Message
Search and you'll find people had the same problem:
http://www.gammon.com.au/forum/bbshowpost.php?bbsubject_id=8841

Zeno McDohl,
Owner of Bleached InuYasha Galaxy
http://www.biyg.org
[Go to top] top

Posted by Nargsbrood   (54 posts)  [Biography] bio
Date Reply #2 on Sun 03 Jul 2011 09:47 PM (UTC)  quote  ]
Message
Thanks Zeno. I believe that did the trick. I am currently running the mud and all commands work. 1 question I have though is it took me 3 times of making clean and make to get it to compile correctly.

The first couple of times I received this error message - first compile reported it between interp.o and liquids.o

the second compile reported it between services.o and sha256.o

the error message was:
g++: error trying to exec '/usr/lib/gcc/i686-pc-cygwin/4.3.4/../../../../i686-pc-cygwin/bin/as.exe': execv: Bad address


any ideas?
[Go to top] top

Posted by Zeno   USA  (2,871 posts)  [Biography] bio   Moderator
Date Reply #3 on Wed 06 Jul 2011 04:21 PM (UTC)  quote  ]
Message
I'm not sure, I don't use Cygwin. Try asking on the FUSS forums or Cygwin mailing list.

Zeno McDohl,
Owner of Bleached InuYasha Galaxy
http://www.biyg.org
[Go to top] top

Posted by Nick Gammon   Australia  (19,497 posts)  [Biography] bio   Forum Administrator
Date Reply #4 on Wed 06 Jul 2011 10:03 PM (UTC)  quote  ]
Message
It looks like as.exe (that is, the "as" command) is the assembler. Not sure why it is giving that error though.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


2,688 views.

[Reply to this subject]  Reply to this subject   [New subject]  Start a new subject   [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

[Home]

Written by Nick Gammon - 5K

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( http://www.gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Web site powered by FutureQuest.Net]