[Home] [Downloads] [Search] [Help/forum]

Gammon Software Solutions forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  MUSHclient
. -> [Folder]  General
. . -> [Subject]  logging
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

logging

[Reply to this subject]  Reply to this subject   [New subject]  Start a new subject   [Refresh] Refresh page


Posted by Feantur   (70 posts)  [Biography] bio
Date Sat 02 Oct 2004 04:28 PM (UTC)  quote  ]
Message
When I'm logging output, for some reason the password I enter seems to be logged _above_ the querying line, despite the line being displayed before I send the password. Is this intended?
[Go to top] top

Posted by Nick Gammon   Australia  (19,384 posts)  [Biography] bio   Forum Administrator
Date Reply #1 on Tue 05 Oct 2004 02:21 AM (UTC)  quote  ]
Message
Can't think why that would be intentional. :)

Maybe it does that because the query doesn't have a linefeed on it.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Feantur   (70 posts)  [Biography] bio
Date Reply #2 on Wed 06 Oct 2004 01:52 PM (UTC)  quote  ]

Amended on Wed 06 Oct 2004 01:59 PM (UTC) by Feantur

Message
Still it would be interesting why the log file looks like this:

As preamble and postamble I use the tags [command] and [/command] & [output] and [/output] in my log file.

[command] heregoesmypassword [/command]
[output] Your password: [/output]

Because, although there might be no linefeed on the second line, shouldn't the command be logged _after_ the output was logged?

P.S. What's definitely weird is that it logs the time of input for the password to be before the actual display of the output of the password query, i.e. as if I sent my password _before_ the query was received (which I don't).

P.P.S. The password doesn't show as input on the active world window, either.
[Go to top] top

Posted by Scypio   Poland  (50 posts)  [Biography] bio
Date Reply #3 on Wed 06 Oct 2004 04:44 PM (UTC)  quote  ]
Message
Speaking of logging the password, I'm wondering if there's a way to suppress it, i.e. so that the password entered is NOT logged..
[Go to top] top

Posted by Flannel   USA  (1,230 posts)  [Biography] bio
Date Reply #4 on Wed 06 Oct 2004 07:17 PM (UTC)  quote  ]
Message
It isnt logged in most cases. Anywhere the server sends echo off isnt logged.

~Flannel

Messiah of Rose
Eternity's Trials.

Clones are people two.
[Go to top] top

Posted by Feantur   (70 posts)  [Biography] bio
Date Reply #5 on Thu 07 Oct 2004 02:55 AM (UTC)  quote  ]
Message
I don't mind the password not being logged, in fact that's rather convenient. :-)
[Go to top] top

Posted by Nick Gammon   Australia  (19,384 posts)  [Biography] bio   Forum Administrator
Date Reply #6 on Thu 07 Oct 2004 09:57 PM (UTC)  quote  ]
Message
I can reproduce that. :)

They are logged in that order because it logs lines when the linefeed arrives, otherwise it might log a partially-received line, or more importantly, triggers fire at the linefeed. A trigger might suppress logging. Thus, the logging cannot occur until after trigger processing.

Now, it sends:

Password: (no linefeed)

Thus that line isn't logged yet.

Then you enter the password. As a command, it is logged.

Then the MUD sends more things (including a linefeed) after receiving the password, so the "Password:" line is now logged.

If you have "auto-connect" set up the password will not appear in the log file. It appears to be a bug that it logs the password the way you are doing it.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Scypio   Poland  (50 posts)  [Biography] bio
Date Reply #7 on Mon 11 Oct 2004 06:06 PM (UTC)  quote  ]
Message
So, is there a way to stop logging the password? (It doesn't show at screen, but it is logged, and I'd prefer it not to).
[Go to top] top

Posted by Meerclar   USA  (569 posts)  [Biography] bio
Date Reply #8 on Mon 11 Oct 2004 06:29 PM (UTC)  quote  ]
Message
To quote Nick:
Quote:
If you have "auto-connect" set up the password will not appear in the log file.

Meerclar - Lord of Cats
Coder, Builder, and Tormenter of Mortals
Stormbringer: Rebirth
storm-bringer.org:4500
www.storm-bringer.org
[Go to top] top

Posted by Scypio   Poland  (50 posts)  [Biography] bio
Date Reply #9 on Mon 11 Oct 2004 06:45 PM (UTC)  quote  ]
Message
I saw that, but my question refers to the situation where I don't have auto-connect (and I don't have it for the reasons which aren't relevant here).
[Go to top] top

Posted by Flannel   USA  (1,230 posts)  [Biography] bio
Date Reply #10 on Mon 11 Oct 2004 07:08 PM (UTC)  quote  ]
Message
Does the server send an echo off message?

~Flannel

Messiah of Rose
Eternity's Trials.

Clones are people two.
[Go to top] top

Posted by Scypio   Poland  (50 posts)  [Biography] bio
Date Reply #11 on Mon 11 Oct 2004 08:55 PM (UTC)  quote  ]
Message
I don't know.. but I think it does, since the password is NOT echoed to the screen, yet it IS logged.
[Go to top] top

Posted by Flannel   USA  (1,230 posts)  [Biography] bio
Date Reply #12 on Mon 11 Oct 2004 09:16 PM (UTC)  quote  ]
Message
Check the "ignore echo off" flag, (config > command )
Does it still happen? (Does it log infront of the prompt)

Does it display infront or behind the prompt?

~Flannel

Messiah of Rose
Eternity's Trials.

Clones are people two.
[Go to top] top

Posted by Scypio   Poland  (50 posts)  [Biography] bio
Date Reply #13 on Mon 11 Oct 2004 09:50 PM (UTC)  quote  ]
Message
Ok, with 'ignore echo off' unchecked the password is not displayed and is logged before the prompt:

Your name?
scypio
xxxxxxxxxx
Password:

With 'ignore echo off' checked the password is displayed (after the prompt) and is logged after the prompt:

Your name?
scypio
Password:
xxxxxxxxxx

[Go to top] top

Posted by Nick Gammon   Australia  (19,384 posts)  [Biography] bio   Forum Administrator
Date Reply #14 on Tue 12 Oct 2004 09:24 PM (UTC)  quote  ]
Message
Added as bug/suggestion #533.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


3,514 views.

[Reply to this subject]  Reply to this subject   [New subject]  Start a new subject   [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

[Home]

Written by Nick Gammon - 5K

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( http://www.gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Internet Contents Rating Association (ICRA) - 2K]    [Web site powered by FutureQuest.Net]