[Home] [Downloads] [Search] [Help/forum]

Gammon Forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  MUSHclient
. -> [Folder]  General
. . -> [Subject]  Send to
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

Send to

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page


Posted by Assassin   (73 posts)  [Biography] bio
Date Tue 31 Aug 2004 06:31 PM (UTC)
Message
I use %1 in a trigger to capture my attacker.

Is their a way of being able to not only use %1
in send box, but also to send a reply to MUD ????

eg:-The (.*?) swipes you!

Can i build "use @w1" in my send somewhere ????
[Go to top] top

Posted by Poromenos   Greece  (1,037 posts)  [Biography] bio
Date Reply #1 on Tue 31 Aug 2004 08:40 PM (UTC)
Message
If the trigger matches, you can use "build %1" (or build "use %1") to send the wildcard.

Vidi, Vici, Veni.
http://porocrom.poromenos.org/ Read it!
[Go to top] top

Posted by Assassin   (73 posts)  [Biography] bio
Date Reply #2 on Tue 31 Aug 2004 08:56 PM (UTC)
Message
Cheers Promo for the reply, not sure if i explained myself
right, what im trying to find out is, if their is a way of
using send to variable, and sending text to the mud at
the same time, from the same trigger..



[Go to top] top

Posted by Flannel   USA  (1,230 posts)  [Biography] bio
Date Reply #3 on Tue 31 Aug 2004 09:43 PM (UTC)
Message
send to : script

and then send (assuming youre using VB):

Send "send message"
SetVariable "variablename", "value"

So, you could use setvariable "target", "%1"
would set your first wildcard to the variable "target"

~Flannel

Messiah of Rose
Eternity's Trials.

Clones are people two.
[Go to top] top

Posted by Assassin   (73 posts)  [Biography] bio
Date Reply #4 on Tue 31 Aug 2004 10:27 PM (UTC)
Message
I think ive tried that, the trigger was setup, and then
converted into a regular expression, maybe thats what is
wrong, it get's the first wildcard and stores it to variable, but when i put my message into send box it doesnt
like it.



[Go to top] top

Posted by Flannel   USA  (1,230 posts)  [Biography] bio
Date Reply #5 on Tue 31 Aug 2004 10:31 PM (UTC)
Message
Why dont you paste your trigger here.

Although, if its matching, then it has nothing to do with your regular expression.

Do you have "send" in front of the things you are trying to send?

like this:
send box:
send "message"

that "Send" prefix is important.

~Flannel

Messiah of Rose
Eternity's Trials.

Clones are people two.
[Go to top] top

Posted by Assassin   (73 posts)  [Biography] bio
Date Reply #6 on Wed 01 Sep 2004 06:25 PM (UTC)
Message
Happy Days......

Cheers Flannel..

Didnt have 'send' wrote in, works a treat...

:)
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


5,280 views.

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

Information and images on this site are licensed under the Creative Commons Attribution 3.0 Australia License unless stated otherwise.

[Home]


Written by Nick Gammon - 5K   profile for Nick Gammon on Stack Exchange, a network of free, community-driven Q&A sites   Marriage equality

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( https://gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Hosted at FutureQuest]