[Home] [Downloads] [Search] [Help/forum]

Gammon Forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  MUSHclient
. -> [Folder]  Bug reports
. . -> [Subject]  Input problem.
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

Input problem.

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page


Posted by Linda   Sweden  (164 posts)  [Biography] bio
Date Mon 10 Jan 2005 04:10 PM (UTC)
Message
Twice in the last weeks I have experienced an odd problem with MUSHclient. All of a sudden, it seems to get confused about the input from my keyboard, for example giving me a - when I typed a + (and those two signs are not even on the same key). When it happens, it happens only in MUSHclient, and a restart of MUSHclient fixes the problem.
[Go to top] top

Posted by Nick Gammon   Australia  (21,386 posts)  [Biography] bio   Forum Administrator
Date Reply #1 on Mon 10 Jan 2005 08:08 PM (UTC)
Message
That happens to me occasionally but every time it does I notice that my keyboard "locale" has changed. For me that is a little box with "EN" in it (for English) on my task bar. Changing it back to EN fixes it.

I am speculating that some keystroke combination is changing it (and that isn't unlikely as I am usually testing macros etc.). If that is true that isn't MUSHclient's problem, the operating system is catching it.

Try seeing if that is the case (the locale change) and see if you can work out what keystrokes change it (I haven't really looked).

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by David Haley   USA  (3,881 posts)  [Biography] bio
Date Reply #2 on Mon 10 Jan 2005 08:11 PM (UTC)
Message
Ctrl-shift and alt-shift are the most common keystrokes for changing input locale, if that helps any.

David Haley aka Ksilyan
Head Programmer,
Legends of the Darkstone

http://david.the-haleys.org
[Go to top] top

Posted by Flannel   USA  (1,230 posts)  [Biography] bio
Date Reply #3 on Mon 10 Jan 2005 08:17 PM (UTC)
Message
Control Panel > Regional and Language Options (and then depending on what version of windows you have, its different) and then on windows XP You click the languages tab, and then the "Details" box about text services and input languages.

You have three options, left alt-shift, or cntrl-shift or... umm, alright, maybe only two options. On previous versions of windows (not XP) there were three choices, if I remember correctly.

~Flannel

Messiah of Rose
Eternity's Trials.

Clones are people two.
[Go to top] top

Posted by Linda   Sweden  (164 posts)  [Biography] bio
Date Reply #4 on Mon 10 Jan 2005 08:21 PM (UTC)
Message
But if that was it, shouldn't it happen in all programs? I tested in several other windows, and there the keyboard functioned normally.
[Go to top] top

Posted by Flannel   USA  (1,230 posts)  [Biography] bio
Date Reply #5 on Mon 10 Jan 2005 08:48 PM (UTC)
Message
Not nessisarily. Windows (by default, I believe you can change it somewhere...) changes languages per program. If you have your language toolbar up (thats the little blue box) you'll see that if you do it in one program, and then switch to another, it changes back to your original language.

~Flannel

Messiah of Rose
Eternity's Trials.

Clones are people two.
[Go to top] top

Posted by David Haley   USA  (3,881 posts)  [Biography] bio
Date Reply #6 on Mon 10 Jan 2005 09:17 PM (UTC)
Message
Yes. WinXP remembers the language you set a program to, until you restart the program. You'd have to make the same language-changing keystroke in another program for it to happen there, too.

What I find odd is that you only just started having this problem; have you perhaps only just started using this kind of keystroke?

David Haley aka Ksilyan
Head Programmer,
Legends of the Darkstone

http://david.the-haleys.org
[Go to top] top

Posted by Flannel   USA  (1,230 posts)  [Biography] bio
Date Reply #7 on Mon 10 Jan 2005 09:23 PM (UTC)

Amended on Mon 10 Jan 2005 09:24 PM (UTC) by Flannel

Message
Or perhaps she just started using multiple languages for her keyboard.

You could disable the hotkey, as you obviously dont seem to be using it much. I believe you can click on the language bar to change it, in lieu of the keyboard combination.

I don't believe Nick can suppress this via Mushclient. I could be wrong though.

~Flannel

Messiah of Rose
Eternity's Trials.

Clones are people two.
[Go to top] top

Posted by Linda   Sweden  (164 posts)  [Biography] bio
Date Reply #8 on Mon 10 Jan 2005 10:01 PM (UTC)
Message
Next time it happens, I'll check to see if it actually has changed the language (I don't have the little toolbar visible, so I won't notice automatically). If so, no prob, really, as I'll know how to change it back.
[Go to top] top

Posted by Poromenos   Greece  (1,037 posts)  [Biography] bio
Date Reply #9 on Tue 11 Jan 2005 09:46 AM (UTC)
Message
Just enable the language toolbar, right click on the taskbar and select Toolbars->Language bar.

Vidi, Vici, Veni.
http://porocrom.poromenos.org/ Read it!
[Go to top] top

Posted by Linda   Sweden  (164 posts)  [Biography] bio
Date Reply #10 on Tue 11 Jan 2005 10:47 AM (UTC)
Message
All of the toolbars are greyed out for me. Probably because I am running classic mode.

Either way, my taskbar is so full that I'll just check manually next time. :)
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


6,420 views.

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

Information and images on this site are licensed under the Creative Commons Attribution 3.0 Australia License unless stated otherwise.

[Home]


Written by Nick Gammon - 5K   profile for Nick Gammon on Stack Exchange, a network of free, community-driven Q&A sites   Marriage equality

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( https://gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Hosted at FutureQuest]