[Home] [Downloads] [Search] [Help/forum]

Gammon Forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  MUSHclient
. -> [Folder]  Bug reports
. . -> [Subject]  Display of text is a bit dodgy
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

Display of text is a bit dodgy

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page


Pages: 1 2  

Posted by Larkin   (278 posts)  [Biography] bio
Date Sat 25 Jun 2005 12:41 AM (UTC)
Message
I know that most people probably don't consider this a bug, if they see it happen at all, but to me it's a bit annoying. What happens is when I connect and receive the initial text (a couple system messages and my current room's description), I get no text update until something else happens in the game, whether it be me executing a command, someone talking, or whatever.

The other part of this bug affects both the output window and the log file. When I sign off, I don't get that last bit of text displayed. There should be a few lines of text confirming that I've successfully logged off, but it never shows. The log is missing even more than that (only a line or two), so I'm wondering what happened to the text and if it would be possible to have this changed to display more uniformly.

If it matters, I'm using the smooth scrolling option (but not the very smooth scrolling).

Thanks in advance.
[Go to top] top

Posted by Flannel   USA  (1,230 posts)  [Biography] bio
Date Reply #1 on Sat 25 Jun 2005 02:33 AM (UTC)
Message
Are you getting those packets (check in packet debug, next time it happens)?

Do you have any plugins that use OnPluginPacketReceived? or any other callbacks? anything like that?

~Flannel

Messiah of Rose
Eternity's Trials.

Clones are people two.
[Go to top] top

Posted by Larkin   (278 posts)  [Biography] bio
Date Reply #2 on Sat 25 Jun 2005 02:41 AM (UTC)
Message
I do have a couple of plugins that use OnPluginPacketReceived to check for prompts without newlines.

The packet debug shows that I receive the lines upon connection, though they are not displayed. It also shows, however, that text is not received when I disconnect. There should be at least a couple more lines before the connection is closed. It's entirely possible that they are products of two separate pieces of code, or that my plugins have done something to get in the way.

If I make a brand new world with no settings at all and login, I see the initial text. When I logoff, I still miss the last few lines.

Hope that helps narrow down the cause of my problems.
[Go to top] top

Posted by David Haley   USA  (3,881 posts)  [Biography] bio
Date Reply #3 on Sat 25 Jun 2005 02:47 AM (UTC)
Message
Does this happen with every MUD you connect to? It could be, at least for the final lines, an error server-side.

I'm not sure quite what you mean about not getting text updates after connecting until something happens. Isn't that, well, normal behavior?

David Haley aka Ksilyan
Head Programmer,
Legends of the Darkstone

http://david.the-haleys.org
[Go to top] top

Posted by Flannel   USA  (1,230 posts)  [Biography] bio
Date Reply #4 on Sat 25 Jun 2005 03:00 AM (UTC)
Message
Are the initial lines that you don't get not terminated by newlines? Are they all in the same packet? Whats the situation?

~Flannel

Messiah of Rose
Eternity's Trials.

Clones are people two.
[Go to top] top

Posted by Larkin   (278 posts)  [Biography] bio
Date Reply #5 on Sat 25 Jun 2005 11:55 AM (UTC)
Message
It happens with any MUD I connect to, which is only two, and they're both IRE MUDs.

Here is the initial debug packets I see that isn't displayed until I do something or something else happens in the game that causes more text to come through, thereby displaying the buffered text before it, also. (I hope this makes some sense.)

Incoming packet: 3 (538 bytes)

...Password corr   ff fc 01 50 61 73 73 77 6f 72 64 20 63 6f 72 72
ect. Welcome to    65 63 74 2e 20 57 65 6c 63 6f 6d 65 20 74 6f 20
Achaea...Your la   41 63 68 61 65 61 2e 0d 0a 59 6f 75 72 20 6c 61
st login was fro   73 74 20 6c 6f 67 69 6e 20 77 61 73 20 66 72 6f
m domain: 69-162   6d 20 64 6f 6d 61 69 6e 3a 20 36 39 2d 31 36 32
-62-103.stcgpa.a   2d 36 32 2d 31 30 33 2e 73 74 63 67 70 61 2e 61
delphia.net.....   64 65 6c 70 68 69 61 2e 6e 65 74 2e 0d 0a 0d 0a
Your moss tattoo   59 6f 75 72 20 6d 6f 73 73 20 74 61 74 74 6f 6f
 tingles slightl   20 74 69 6e 67 6c 65 73 20 73 6c 69 67 68 74 6c
y...Your boar ta   79 2e 0d 0a 59 6f 75 72 20 62 6f 61 72 20 74 61
ttoo tingles sli   74 74 6f 6f 20 74 69 6e 67 6c 65 73 20 73 6c 69
ghtly....[33mRoa   67 68 74 6c 79 2e 0d 0a 1b 5b 33 33 6d 52 6f 61
d past a Shastaa   64 20 70 61 73 74 20 61 20 53 68 61 73 74 61 61
n guard hut .[37   6e 20 67 75 61 72 64 20 68 75 74 20 1b 5b 33 37
m(road)....[36mA   6d 28 72 6f 61 64 29 2e 0d 0a 1b 5b 33 36 6d 41
n obsidian eye s   6e 20 6f 62 73 69 64 69 61 6e 20 65 79 65 20 73
igil is here..[3   69 67 69 6c 20 69 73 20 68 65 72 65 2e 1b 5b 33
7m.[36m...[37m.[   37 6d 1b 5b 33 36 6d 0d 0a 1b 5b 33 37 6d 1b 5b
1;34mYou see exi   31 3b 33 34 6d 59 6f 75 20 73 65 65 20 65 78 69
ts leading.[0;37   74 73 20 6c 65 61 64 69 6e 67 1b 5b 30 3b 33 37
m.[1;34m north (   6d 1b 5b 31 3b 33 34 6d 20 6e 6f 72 74 68 20 28
open door), east   6f 70 65 6e 20 64 6f 6f 72 29 2c 20 65 61 73 74
, south, and wes   2c 20 73 6f 75 74 68 2c 20 61 6e 64 20 77 65 73
t....[0;37m.[32m   74 2e 0d 0a 1b 5b 30 3b 33 37 6d 1b 5b 33 32 6d
3576h,.[37m.[32m   33 35 37 36 68 2c 1b 5b 33 37 6d 1b 5b 33 32 6d
 2820m,.[37m.[32   20 32 38 32 30 6d 2c 1b 5b 33 37 6d 1b 5b 33 32
m 15835e,.[37m.[   6d 20 31 35 38 33 35 65 2c 1b 5b 33 37 6d 1b 5b
32m 13000w.[37m    33 32 6d 20 31 33 30 30 30 77 1b 5b 33 37 6d 20
ex-...[32m3576h,   65 78 2d ff f9 1b 5b 33 32 6d 33 35 37 36 68 2c
.[37m.[32m 2820m   1b 5b 33 37 6d 1b 5b 33 32 6d 20 32 38 32 30 6d
,.[37m.[32m 1583   2c 1b 5b 33 37 6d 1b 5b 33 32 6d 20 31 35 38 33
5e,.[37m.[32m 13   35 65 2c 1b 5b 33 37 6d 1b 5b 33 32 6d 20 31 33
000w.[37m ex-...   30 30 30 77 1b 5b 33 37 6d 20 65 78 2d ff f9 ff
.......V..         fc 19 ff fc c8 ff fa 56 ff f0

Sent  packet: 7 (3 bytes)

...                ff fe 19

Sent  packet: 8 (3 bytes)

...                ff fe c8


On the left, I can see that the description of the room was sent to me, but it wasn't in the display window yet.

The text that doesn't get sent to me on disconnecting isn't in the display or in the debug packets, and it's not a server-side problem because it works in any other client that I try.
[Go to top] top

Posted by David Haley   USA  (3,881 posts)  [Biography] bio
Date Reply #6 on Sat 25 Jun 2005 06:47 PM (UTC)
Message
Seems that the server isn't sending an echo-on request, given that the echo-off is sent right before typing your password.

What bothers me in all of this is that empirical evidence shows that MUSHclient works for a whole lot of people, so something fishy is going on here. Have you tried connecting to another MUD?

David Haley aka Ksilyan
Head Programmer,
Legends of the Darkstone

http://david.the-haleys.org
[Go to top] top

Posted by Larkin   (278 posts)  [Biography] bio
Date Reply #7 on Sat 25 Jun 2005 06:53 PM (UTC)
Message
As I said, I don't play any other MUD and this seems to have something to do with my world settings. I do recall seeing something about ignoring 'echo off' messages and never knew why I'd want that option. I'll see if that helps part of my problem, but the fact still remains that the trailing text on logoff isn't displayed.

Thanks for your help.
[Go to top] top

Posted by Flannel   USA  (1,230 posts)  [Biography] bio
Date Reply #8 on Sat 25 Jun 2005 07:09 PM (UTC)
Message
You shouldn't have to ignore echo off messages, the server should send a NOECHO after you send your password (which turns off HIDE YOUR INPUT). So the first bit is a server issue, or at least seems to be.

The last bit, I have a feeling that debug packets only happens after plugins are done dealing with them. Try disabiling your plugins and see if the problem still persists.

~Flannel

Messiah of Rose
Eternity's Trials.

Clones are people two.
[Go to top] top

Posted by Larkin   (278 posts)  [Biography] bio
Date Reply #9 on Sat 25 Jun 2005 07:38 PM (UTC)
Message
I removed all plugins, unchecked the Ignore Echo Off option, and when I connected the text was still hidden. Checking the Ignore Echo Off option seemed to take care of the first part of the problem, but I agree with you that I shouldn't have to use the option. I would find it difficult to believe that it could be the server, however, as other clients don't exhibit this same behavior.
[Go to top] top

Posted by Flannel   USA  (1,230 posts)  [Biography] bio
Date Reply #10 on Sat 25 Jun 2005 08:34 PM (UTC)
Message
Other clients probably ignore the spec that says that the client won't decide when to turn text back on. That's usually the case in this sort of thing, of course, I could be wrong, only way to know would be to see the whole initial login packets. Would you mind turning off your autologin, logging in by hand (with debug packets), and then going until the text shows, and posting that here? You'll obviously want to change your password to something else during this proccess (so we get the dummy password).

Does the lack of plugins fix the logoff problem?

~Flannel

Messiah of Rose
Eternity's Trials.

Clones are people two.
[Go to top] top

Posted by David Haley   USA  (3,881 posts)  [Biography] bio
Date Reply #11 on Sat 25 Jun 2005 11:34 PM (UTC)
Message
I don't think you understand why I'm asking you to connect to another MUD. I hadn't forgotten that you said you didn't play anywhere else. That's not the point. I'm trying to narrow down the problem. As I said, empirical evidence goes to show that it's not a problem with MUSHclient. If you manage to connect to another server and everything works, then we know that something is wrong with the MUD you play on or your settings with it. If the problem occurs with another MUD, then it is likely that you have a bad configuration e.g. with plugins, but we have ruled out the server-side error.

David Haley aka Ksilyan
Head Programmer,
Legends of the Darkstone

http://david.the-haleys.org
[Go to top] top

Posted by Larkin   (278 posts)  [Biography] bio
Date Reply #12 on Sun 26 Jun 2005 12:51 AM (UTC)
Message
I will work on getting a better set of debug packets for you to look at. It's quite possible that the autologin sequence is what causes my problem, too. We'll see if it looks any different at all.

The lack of plugins didn't change the text problem at logoff.

I understand that you want me to connect to another MUD to see differences, but I don't see how that is directly relevant to my particular situation. I'm not blaming MUSHclient for the problem on login, necessarily, but the logoff thing definitely seems to be something particular to this client.

Thanks again for your assistance, and I'll get back to you soon with more information.
[Go to top] top

Posted by David Haley   USA  (3,881 posts)  [Biography] bio
Date Reply #13 on Sun 26 Jun 2005 01:40 AM (UTC)
Message
Quote:
but the logoff thing definitely seems to be something particular to this client.
No, it definitely does not seem to be particular to MUSHclient, else other people would be having it. Connecting to other MUDs is relevant to your situation for the reason I explained: it narrows down the problem. If of course you'd rather fix your problem some other way, feel free to do so.

David Haley aka Ksilyan
Head Programmer,
Legends of the Darkstone

http://david.the-haleys.org
[Go to top] top

Posted by Larkin   (278 posts)  [Biography] bio
Date Reply #14 on Sun 26 Jun 2005 02:21 AM (UTC)
Message
The logoff thing cannot be narrowed down, in my opinion. Disconnecting with any number of other clients works as expected and shows all of the text. With MUSHclient, I don't even see the text in debug packets, so obviously something has gone missing. It has nothing to do with my settings. I've asked others who use MUSHclient on these same MUDs and they say they just accepted the behavior and don't know how to fix it. So, not just me here.

Taking out the name and password from the Connecting commands makes the text appear, but entering my name and password by hand isn't as secure as I'd like. I use autologin because I want it to keep my password undisplayed without making a trigger (with my password in it) to omit the password.

Connecting to another MUD requires me to create another character, choose a password, go through the steps to ensure my character is saved long enough for me to make a few attempts at this. I tried Medievia and it not only requires me to get to level two to save my character, it confuses me as to how to even do so. I don't have time to mess with other MUDs, and if that's what it takes to get this problem solved, I'll live with it.

I apologize if I've offended your sensibilities, but I'm simply trying to report a problem and ask for a little help. I'm tired and I'm not going to mess with it any more for now. Thanks anyway.
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


15,785 views.

This is page 1, subject is 2 pages long: 1 2  [Next page]

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

Information and images on this site are licensed under the Creative Commons Attribution 3.0 Australia License unless stated otherwise.

[Home]


Written by Nick Gammon - 5K   profile for Nick Gammon on Stack Exchange, a network of free, community-driven Q&A sites   Marriage equality

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( https://gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Hosted at FutureQuest]