[Home] [Downloads] [Search] [Help/forum]

Gammon Forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  MUSHclient
. -> [Folder]  General
. . -> [Subject]  Bypassing the "disconnected from the <name here> server" notification
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

Bypassing the "disconnected from the <name here> server" notification

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page


Posted by Silverwood   (12 posts)  [Biography] bio
Date Thu 31 Dec 2009 10:48 PM (UTC)
Message
Recently I've been having problems with my wireless, which makes some MUD servers randomly disconnect me due whenever the signal gives out.

This normally wouldn't be a problem as I've created triggers that automatically log myself in on disconnection. But for idling purposes, it does become a bit frustrating as the only thing keeping me from being online when I'm away is the "you have been disconnected from the <name here> server" notification popup that keeps on appearing whenever I'm disconnected. It requires me to press <Enter> or click <OK>, neither of which I'm able to do when I'm away. MUSHclient also pauses for my response when this happens.

My question is: are there any ways I can bypass this notification, perhaps by changing view or notification settings in the client? As always, thank you very much for your help!
[Go to top] top

Posted by Twisol   USA  (2,257 posts)  [Biography] bio
Date Reply #1 on Thu 31 Dec 2009 11:02 PM (UTC)
Message
Sure; go to File -> Global Preferences -> General tab, and uncheck the "Notify me when connection broken" box.

You may also want to look into setting the "send_keepalives" option, only accessible via script. It'll send TCP keepalives over the connection, protocol-level packets with no data that simply assure both sides that the connection wasn't somehow severed. Normally, if the server doesn't send you any data and you don't send any commands, for an extended period of time, then the connection will automatically time out and become severed; the typical timeframe is thirty minutes if I recall correctly. You can enable it with this (Lua) code, which only needs to be run once; just before to save your world file (Ctrl+S) afterwards, and disconnect/reconnect to make it effective:

SetOption("send_keepalives", 1)

'Soludra' on Achaea

Blog: http://jonathan.com/
GitHub: http://github.com/Twisol
[Go to top] top

Posted by Nick Gammon   Australia  (21,651 posts)  [Biography] bio   Forum Administrator
Date Reply #2 on Fri 16 Jul 2010 09:41 PM (UTC)

Amended on Fri 16 Jul 2010 09:42 PM (UTC) by Nick Gammon

Message
Actually:


SetOption("send_keep_alives", 1)


- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


2,807 views.

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

Information and images on this site are licensed under the Creative Commons Attribution 3.0 Australia License unless stated otherwise.

[Home]


Written by Nick Gammon - 5K   profile for Nick Gammon on Stack Exchange, a network of free, community-driven Q&A sites   Marriage equality

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( https://gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Hosted at FutureQuest]