[Home] [Downloads] [Search] [Help/forum]

Gammon Software Solutions forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  MUSHclient
. -> [Folder]  General
. . -> [Subject]  Configuring Netscape to use Mushclient for Telnet.
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

Configuring Netscape to use Mushclient for Telnet.

[Reply to this subject]  Reply to this subject   [New subject]  Start a new subject   [Refresh] Refresh page


Posted by Magnum   Canada  (580 posts)  [Biography] bio
Date Tue 07 May 2002 04:21 AM (UTC)  quote  ]
Message
I am trying to configure Netscape to use Mushclient as the default program for opening a telnet connection. Here's the problem:

I can click on Preferences|Navigator|Applications, then find the "URL: Telnet Protocol" assocation and edit it.

I've tried entering:

"C:\Program Files\MUSHclient\MUSHclient.exe" %1

...but that won't work. The problem is that the argument that gets passed is in the format: "216.218.240.103:10000", but MushClient will only open an address and port number if they are passed like this "216.218.240.103 10000". In other words, the port number must be passed as a second argument, not part of the first.

I don't know if it is possible to tell Netscape to rip off the port number from "216.218.240.103:10000" and pass it as a second argument... I doubt it.

Nick, I suppose you should consider this a suggestion to allow mushclient to accept a URL in this format: "216.218.240.103:10000", unless you have another solution to this problem.

Get my plugins here: http://www.magnumsworld.com/muds/

Constantly proving I don't know what I am doing...
Magnum.
[Go to top] top

Posted by Shadowfyr   USA  (1,775 posts)  [Biography] bio
Date Reply #1 on Tue 07 May 2002 08:50 PM (UTC)  quote  ]
Message
Hmm. I would definitely suggest changing that. Standard port and address info is always 'address:port'. I find it very unlikely that any program would pass these things to another by sliptting them up. On the other hand : has special meaning in DOS if I remember right and coding something into the program to work around the problem could be complicated. I think : is a delimiter or something, so it may not even be seeing the port number. You could try using:

"C:\Program Files\MUSHclient\MUSHclient.exe" "%1"

since then windows 'should in theory' treat it as a string being sent, rather than different bits of data. Whether MUSHClient will then split it up correctly or not is another matter.

main {
__if (Schrodinger_Cat is Alive or version >= "XP"){
____if version = "Vista" then Performance /= Number_of_Cores;
____call Functional_Code();}
__else
____call Crash_Windows();}
[Go to top] top

Posted by Magnum   Canada  (580 posts)  [Biography] bio
Date Reply #2 on Wed 08 May 2002 12:57 AM (UTC)  quote  ]

Amended on Wed 08 May 2002 12:59 AM (UTC) by Magnum

Message
Still doesn't work. Indeed, Mushclient fail to connect message displays too may quotes, so they are prolly being handed over as literal argument characters...

Oh, and Mushclient displays the full URL, including the port number in the error. It's getting the port number, it just isn't seperating it from the URL.

Get my plugins here: http://www.magnumsworld.com/muds/

Constantly proving I don't know what I am doing...
Magnum.
[Go to top] top

Posted by Nick Gammon   Australia  (19,173 posts)  [Biography] bio   Forum Administrator
Date Reply #3 on Wed 08 May 2002 03:04 AM (UTC)  quote  ]
Message
Well, that was so easy to change I almost laughed. :)

I had to change:


int iSpace = strCommandLine.Find (" ");



to


int iSpace = strCommandLine.FindOneOf (" :");



That will be available in 3.20.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Magnum   Canada  (580 posts)  [Biography] bio
Date Reply #4 on Wed 08 May 2002 05:22 AM (UTC)  quote  ]
Message
I hope it doesn't barf on a full URL, like telnet://123.456.789.012:1234

I think it will, I just checked yet again, and the "telnet://" is included in the can't connect message.

You should check for that as well, and handle the string accordingly.

Get my plugins here: http://www.magnumsworld.com/muds/

Constantly proving I don't know what I am doing...
Magnum.
[Go to top] top

Posted by Nick Gammon   Australia  (19,173 posts)  [Biography] bio   Forum Administrator
Date Reply #5 on Wed 08 May 2002 05:54 AM (UTC)  quote  ]
Message
Just caught me as I was about to release 3.20. I will put that in too.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Magnum   Canada  (580 posts)  [Biography] bio
Date Reply #6 on Wed 08 May 2002 06:06 AM (UTC)  quote  ]
Message
I use http://www.topmudsites.com/ to test the linking...

One last thing I just thought of:

Might be nice if Mushclient looks to see if it already has the address in one of the saved worlds, and uses that world's files accordingly.

Perhaps it does that already?

Would be better than opening the world with the default settings... (because mushclient did NOT check).

Get my plugins here: http://www.magnumsworld.com/muds/

Constantly proving I don't know what I am doing...
Magnum.
[Go to top] top

Posted by Nick Gammon   Australia  (19,173 posts)  [Biography] bio   Forum Administrator
Date Reply #7 on Wed 08 May 2002 06:41 AM (UTC)  quote  ]
Message
Another day perhaps. You might have a lot of saved worlds - I know I do. :)

What if more than one matched the address (eg. admin, mortal). What would it do then?

Anyway, version 3.20 is available to play with.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Linda   Sweden  (164 posts)  [Biography] bio
Date Reply #8 on Wed 08 May 2002 10:57 AM (UTC)  quote  ]
Message
Its great to finally be able to click on a telnet link in Netscape and have it parse correctly, but a few problems may still remain. :)

Is it possible to pass the /noauto switch to the standard telnet setup? Currently, I use C:\MUSH\MushClient\MUSHclient.exe %1 /noauto

That does open a link I click on, but it also opens all worlds in my startup list, connecting me twice if I already have an instance of MUSHclient running.

If that isn't possible, even better would be if MUSHclient is open when you click on a telnet link, the new world opens in the existing copy. Maybe that could be a user choice?
[Go to top] top

Posted by Nick Gammon   Australia  (19,173 posts)  [Biography] bio   Forum Administrator
Date Reply #9 on Wed 08 May 2002 09:07 PM (UTC)  quote  ]
Message
Unfortunately I made /noauto and the supplied ip address mutually exclusive, for reasons that elude me. :)

I suggest for the moment, either:

1. Hold down the Shift key as MUSHclient starts up (after clicking on the link in Netscape) - this disables the auto open.

2. Instead of auto-open in the global prefs, do a manual version with a small script, which you call from an alias. Something like this:

world.open "c:\mushclient\world1.mcl"
world.open "c:\mushclient\world2.mcl"
world.open "c:\mushclient\world3.mcl"

Your alias (eg. "openall") would be typed when you want to open all of them.

I have added the suggestion as #464.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


3,863 views.

[Reply to this subject]  Reply to this subject   [New subject]  Start a new subject   [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

[Home]

Written by Nick Gammon - 5K

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( http://www.gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Internet Contents Rating Association (ICRA) - 2K]    [Web site powered by FutureQuest.Net]