[Home] [Downloads] [Search] [Help/forum]

Gammon Software Solutions forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  MUSHclient
. -> [Folder]  Bug reports
. . -> [Subject]  ICS Issues?
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

ICS Issues?

It is now over 60 days since the last post. This thread is closed.   [New subject]  Start a new subject   [Refresh] Refresh page


Posted by Java Head   (3 posts)  [Biography] bio
Date Sun 15 Apr 2001 10:51 PM (UTC)  quote  ]
Message
I have recently upgraded our two computers to WinME. Since I had problems getting IPX/SPX to recognize our little network I set up Internet Connection Sharing with my system as 'host'. I am connected direct to the DSL modem, and she is connected to me through a hub.

The problem is that she keeps getting dropped offline with no warning, or 'are you sure' confirmation. Does anyone know of an ICS timeout period? Does MushClient give up after so long? Can this be fixed?

It happens in all worlds apparently. She is using the latest registered version.
[Go to top] top

Posted by Nick Gammon   Australia  (19,613 posts)  [Biography] bio   Forum Administrator
Date Reply #1 on Tue 17 Apr 2001 12:27 AM (UTC)  quote  ]
Message
I am not familiar with this Internet Connection Sharing product.

MUSHclient does not drop a connection after any time - once established it can stay up for days.

I suggest browsing the Windows Knowledge Base, looking for keywords like "ICS" and "timeout".

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Linda   Sweden  (164 posts)  [Biography] bio
Date Reply #2 on Tue 17 Apr 2001 10:18 AM (UTC)  quote  ]
Message
I've actually had the same problem over a network (using Sygate, not ICS); if the MUSHclient on the client side of the network doesn't see any activity for 5-10 minutes, it will drop connection. The only solution to this has been to have a timer fire every 5 minutes.
[Go to top] top

Posted by Nick Gammon   Australia  (19,613 posts)  [Biography] bio   Forum Administrator
Date Reply #3 on Sat 21 Apr 2001 04:47 AM (UTC)  quote  ]
Message

I have read about some utilities that you can use with ICS to help stop it disconnecting on idle.

Apparently the default timeout for ICS is 300 seconds (5 minutes) which would explain the disconnections you are experiencing.

Remote Disconnection Utility, from www.twiga.ltd.uk

ICS Configuration Utility, from www.practicallynetworked.com


- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by RogerO   (1 post)  [Biography] bio
Date Reply #4 on Tue 08 May 2001 11:52 PM (UTC)  quote  ]
Message
I have been having a connection problem when using MUSH via a firewall. The firewall is configured to timeout idle connections in 5 minutes. (Sounds similar to the ICS connection problem.) To fix, I configred a trigger that fires every 3 minutes and sends a non-printable character to the server. The server drops the character (a vertical tab) and does not forward to other uses, but this refreshes the connection, so that the firewall does not drop it.

Roger
[Go to top] top

Posted by Vbmoneymaker   (1 post)  [Biography] bio
Date Reply #5 on Fri 01 Jun 2001 02:36 AM (UTC)  quote  ]
Message
Dear Java Head:

I think I may have a fix for you. I had the same problem with my ICS which I was using to connect to my Verizon DSL via a dsl modem. There were two things going wrong. First, there was the timeout issue where ICS would disconnect after 5 minutes of non-use on the gateway machine connected directly to the DSL modem. I fixed this as suggested on several other sites by going into the registry and changing the Hangup value for ICS. The next problem was something I only discovered after downloading the ICScfg program by Harley Acheson. What happened when I did this is that the program told me the ICS service wasn't installed. I got this message even though ICS was clearly installed given that I was able to connect to the Internet through it and given that when I double-clicked the ICS icon in the taskbar, ICS said that it was enabled.

What I eventually discovered was that even though ICS was working, it was showing up in the registry key as being uninstalled. I don't know why this was, but the fix was simple. I simply changed the install value to '1' so that ICS would be recognized as being installed. I then rebooted and now I don't have anymore disconnection problems. Both of these fixes were apparently necessary because without ICS being recognized, the change in the hangup value from the default of 300 seconds to whatever you want it set at, was not being recognized. Once ICS was being recognized, then the change in the timeout value also was recognized. By the way, I changed my timeout value from 300 to 100000000000 so that I don't have to worry about the timeout occurring again for about another 3 years.
[Go to top] top

Posted by Java Head   (3 posts)  [Biography] bio
Date Reply #6 on Sat 09 Jun 2001 04:09 PM (UTC)  quote  ]
Message
Hey great stuff, thanks!
Do I set the timeout settings on the ics server, or the ics workstation (the poor guy having to go through my system) or both?
Can I get the registry's keyname I'm looking for?

Can I get any URLs to the 3rd party software that was mentioned ?

javahd@hotmail.com

\|/ ____ \|/
~@_/ Oo \_@~ Jesters Do It Till Ya Smile!
/_( \__/ )_\
\__U_/
[Go to top] top

Posted by Java Head   (3 posts)  [Biography] bio
Date Reply #7 on Sat 09 Jun 2001 04:11 PM (UTC)  quote  ]
Message
....\|/ ____ \|/....
....~@_/ Oo \_@~.... Jesters Do It Till Ya Smile!
..../_( \__/ )_\....
.......\__U_/.......
[Go to top] top

Posted by Amenti   USA  (8 posts)  [Biography] bio
Date Reply #8 on Sat 23 Jun 2001 10:37 PM (UTC)  quote  ]
Message
Actually, reading through the messages, I wanted to note that I use Sygate and there is a way to correct the problem of client machines disconnecting worlds using MUSHClient.

What you need to do is this. Go to the computer set as the Sygate Host/Server machine. Open the sygate manager. At the top of the window, open the advanced tab. This should open another section of the manager where you'll find a button called Configuration. Click on this button and the Configuration options for Sygate will open. At the bottom of this screen, click on the advanced button, in there you will see an option for setting Connection Time out. The default is the equivalent of 10 minutes. Change that value to 1439. This will give you just under 24 hours, before the timeout will occur on the client machines.
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


6,507 views.

It is now over 60 days since the last post. This thread is closed.   [New subject]  Start a new subject   [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

[Home]

Written by Nick Gammon - 5K

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( http://www.gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Web site powered by FutureQuest.Net]