[Home] [Downloads] [Search] [Help/forum]

Gammon Software Solutions forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  MUSHclient
. -> [Folder]  Bug reports
. . -> [Subject]  EchoInput False after modifying World Properties.
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

EchoInput False after modifying World Properties.

It is now over 60 days since the last post. This thread is closed.   [New subject]  Start a new subject   [Refresh] Refresh page


Pages: 1 2  

Posted by Magnum   Canada  (580 posts)  [Biography] bio
Date Mon 10 Dec 2001 04:48 AM (UTC)  quote  ]
Message
I am surprised no one has mentioned this before, so I hope it's not a problem unique to me...

Whenever I return to the main screen after making changes in the World Properties (Adding an alias, trigger, etc), the EchoInput is set to False.

My workaround is that I have created an alias specifically set to turn EchoInput on, but I consider this a bug.

Can anyone verify this bug?

Get my plugins here: http://www.magnumsworld.com/muds/

Constantly proving I don't know what I am doing...
Magnum.
[Go to top] top

Posted by Nick Gammon   Australia  (19,608 posts)  [Biography] bio   Forum Administrator
Date Reply #1 on Mon 10 Dec 2001 05:41 AM (UTC)  quote  ]
Message
I can't reproduce that. What version are you using? When you say "false" you mean it becomes zero?

So, you do this ... ?


  • You type: /world.note world.getoption ("EchoInput")
  • You see -1 echoed
  • You modify world properties
  • You type: /world.note world.getoption ("EchoInput")
  • You see 0 echoed


- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Magnum   Canada  (580 posts)  [Biography] bio
Date Reply #2 on Tue 11 Dec 2001 09:30 AM (UTC)  quote  ]
Message
Between the lines '---' is pasted output from the MUD:

---
>
think Testing.
You . o O ( Testing. ).
>
-1
think About to press trigger button on menu bar, then ok on dialog box...
You . o O ( About to press trigger button on menu bar, then ok on dialog box... ).
> You . o O ( Testing ).
>
-1
You . o O ( -1, but notice my commands are NOT echoed to the mud. ).
> You . o O ( About to use 'eon' alias to set EchoInput to True... ).
> >
think Alias 'eon' was used.
You . o O ( Alias 'eon' was used. ).
-1
---

Musclient version 3.17

Get my plugins here: http://www.magnumsworld.com/muds/

Constantly proving I don't know what I am doing...
Magnum.
[Go to top] top

Posted by Magnum   Canada  (580 posts)  [Biography] bio
Date Reply #3 on Tue 11 Dec 2001 09:33 AM (UTC)  quote  ]
Message
Perhaps EchoInput is not being set to False, but the client is acting like it has. The alias to set EchoInput to True works as a means of currecting the problem.

Get my plugins here: http://www.magnumsworld.com/muds/

Constantly proving I don't know what I am doing...
Magnum.
[Go to top] top

Posted by Nick Gammon   Australia  (19,608 posts)  [Biography] bio   Forum Administrator
Date Reply #4 on Tue 11 Dec 2001 08:23 PM (UTC)  quote  ]
Message
I can't really explain that. No-one else has reported it. Judging by the -1 which I presume is the echoinput variable, it is not in fact changing.

There are a couple of other ways input might not be echoed:

1. An alias which has "omit from output" checked. I can't explain why that would suddenly activate after showing the world configuration.

2. Check under the Display menu to see if "no command echo" has become checked. This is controlled by a telnet sequence from the MUD. Perhaps that variable is somehow becoming corrupted.

If that is the case go to the Output configuration and check "Ignore 'echo off' messages"

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Magnum   Canada  (580 posts)  [Biography] bio
Date Reply #5 on Wed 12 Dec 2001 12:07 AM (UTC)  quote  ]
Message
I have found the problem.

Blame it on me. Chalk another one up to human error. Doh!

Configuration | Input | Commands | [checkbox]Echo My Input In:

..was UNchecked.

Of course, now everything makes sense.

When I brought up the configuration menu, and clicked "ok", that setting would turn off the echo. I almost never visit that particular configuration screen anymore, so it must have slipped past me when I was looking for the cause of my problem.

Thanks Nick, and my appologies for error on my part.

I see that you are very quick to respond to questions. Your software DOES work reliably.
You are one awesome dude. :)

Get my plugins here: http://www.magnumsworld.com/muds/

Constantly proving I don't know what I am doing...
Magnum.
[Go to top] top

Posted by Linda   Sweden  (164 posts)  [Biography] bio
Date Reply #6 on Wed 12 Dec 2001 12:34 PM (UTC)  quote  ]
Message
Actually, I have had some problems with echo input as well. Occasionally, it seems to turn itself off, although the box stays checked. I can fix it by unchecking the box, applying and then rechecking the box and applying again, but I haven't been able to track down what it is that causes it.
[Go to top] top

Posted by Nick Gammon   Australia  (19,608 posts)  [Biography] bio   Forum Administrator
Date Reply #7 on Wed 12 Dec 2001 08:42 PM (UTC)  quote  ]
Message
It could be the telnet sequence that stops echo, as I mentioned earlier. For instance, if you enter a password, servers typically turn echo off.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Magnum   Canada  (580 posts)  [Biography] bio
Date Reply #8 on Thu 13 Dec 2001 04:33 AM (UTC)  quote  ]
Message
Just to update...

I've found that the setting I mention above, is somehow being turned off without my explicit permission.

I've now also checked the box that Nick recommended, and I'll see how the client reacts from this point forward.

Get my plugins here: http://www.magnumsworld.com/muds/

Constantly proving I don't know what I am doing...
Magnum.
[Go to top] top

Posted by Magnum   Canada  (580 posts)  [Biography] bio
Date Reply #9 on Sat 15 Dec 2001 12:18 PM (UTC)  quote  ]
Message
Ok, I've had both boxes checked, and the problem still occurs.

For some reason, the checkbox I mentioned above ([x]Echo My Input In: [Color]) keeps getting unchecked!

This happens even when "[x]Ignore 'Echo Off' Messages" is checked.

I don't want to have to re-check that box every time I make a configuration change (elsewhere). It's easir to keep using my 'eon' alias.

I don't know why the box keeps unchecking itself. IMHO, this IS a bug. I don't know what could be causing it, although if I were to speculate, I would guess that maybe issueing "EchoInput = False" in a script somehow unchecks the box ... (yet setting it to True does not check it again).

I can't speculate as to why I seem to be the only one with this problem. Is it because I am a 'rare' person who uses "EchoInput = False" in my script?

Get my plugins here: http://www.magnumsworld.com/muds/

Constantly proving I don't know what I am doing...
Magnum.
[Go to top] top

Posted by Nick Gammon   Australia  (19,608 posts)  [Biography] bio   Forum Administrator
Date Reply #10 on Sun 16 Dec 2001 10:06 PM (UTC)  quote  ]
Message
This isn't similar to the earlier problem is it? Make sure you save the world file after making changes, otherwise they'll be back to where they were next time you load the world.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Magnum   Canada  (580 posts)  [Biography] bio
Date Reply #11 on Mon 17 Dec 2001 06:00 AM (UTC)  quote  ]
Message
I hit the "save" icon after every change I make, and also save the world file via prompt when I close the program.

Get my plugins here: http://www.magnumsworld.com/muds/

Constantly proving I don't know what I am doing...
Magnum.
[Go to top] top

Posted by Nick Gammon   Australia  (19,608 posts)  [Biography] bio   Forum Administrator
Date Reply #12 on Mon 17 Dec 2001 08:19 AM (UTC)  quote  ]
Message
Better email me the world file so I can try it myself. You are the only one to report this, and it certainly never happens to me.

I have "echo input" on, and am always making configuration changes, partly to repond to messages here. :)

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Nick Gammon   Australia  (19,608 posts)  [Biography] bio   Forum Administrator
Date Reply #13 on Tue 18 Dec 2001 08:10 PM (UTC)  quote  ]

Amended on Tue 18 Dec 2001 08:11 PM (UTC) by Nick Gammon

Message
I can see one problem - there is a discrepancy between what EchoInput usually is, and what you are setting it to in the script. :)

For example, in your script:


Sub World_Initialize
' ... other things here ...
World.Note "World Initialized."
World.EchoInput = vbTrue
End Sub


You are setting EchoInput to vbTrue. However if you try this, you will see that there is a discrepancy between vbTrue and using the configuration screen ...


/world.note world.EchoInput
(response) 1
/world.EchoInput = vbFalse
/world.note world.EchoInput
(response) 0
/world.EchoInput = vbTrue
/world.note world.EchoInput
(response) -1


Note how EchoInput has gone from 1 to -1?

Now when you bring up the configuration screen a second time, it interprets -1 as "not true" and sets EchoInput to zero.

Thus, your problem will go away if you change your scripts to do this:


/world.EchoInput = 1 ' make true
/world.EchoInput = 0 ' make false


I admit this is a semi-bug, but in my defence I refer you to the web page:


http://www.gammon.com.au/scripts/function.php?action=prototypes


In it it refers to boolean values and says:


"The safest way to test for "true" or "false" is to assume that zero (0) is false, and any other value is true.

Similarly, to supply the value "true" simply supply a 1, and to supply the value "false", supply the value 0."


Thus the web page explicitly recommends using "1" as true and not some other non-zero value. :)


- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Magnum   Canada  (580 posts)  [Biography] bio
Date Reply #14 on Wed 19 Dec 2001 12:30 AM (UTC)  quote  ]
Message
Ahh, looks like I made an 'ass' out of 'u' and 'me' (as the old saying goes).

:)

For convenience, I created the following variables in my script:

Const vbsTrue = 1
Const vbsFalse = 0

...I then did a search & replace, changing all 'vbTrue' to 'vbsTrue' and similar S&R for 'vbsFalse'.

Hopefully, this will correct all problems. :)

For consistency's sake, if you haven't already, you may wish to add this to your bug list. (I also noticed that the plain built-in constants 'True' and 'False' also use '-1' and '0' ...like their vb- counterparts).

Get my plugins here: http://www.magnumsworld.com/muds/

Constantly proving I don't know what I am doing...
Magnum.
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


6,692 views.

This is page 1, subject is 2 pages long: 1 2  [Next page]

It is now over 60 days since the last post. This thread is closed.   [New subject]  Start a new subject   [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

[Home]

Written by Nick Gammon - 5K

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( http://www.gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Web site powered by FutureQuest.Net]