[Home] [Downloads] [Search] [Help/forum]

Gammon Software Solutions forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  MUSHclient
. -> [Folder]  Jscript
. . -> [Subject]  Can't run Java plugin
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

Can't run Java plugin

[Reply to this subject]  Reply to this subject   [New subject]  Start a new subject   [Refresh] Refresh page


Posted by Zirnitra   (8 posts)  [Biography] bio
Date Wed 23 Dec 2009 08:46 PM (UTC)  quote  ]
Message
I'm trying to run a batch file to start a UI plugin but I just get a command prompt that flashes up and disappears. I have the JRE installed, but the "java" command isn't even recognised when typed into a cmd window. Anyone understand what's wrong here?
[Go to top] top

Posted by Twisol   USA  (2,230 posts)  [Biography] bio
Date Reply #1 on Wed 23 Dec 2009 08:53 PM (UTC)  quote  ]

Amended on Wed 23 Dec 2009 08:59 PM (UTC) by Twisol

Message
Well, firstly, Java Isn't Javascript, and I don't believe Java is supported by MUSHclient as a scripting language. It sounds like you're talking about an external program rather than a MUSHclient plugin, so that complicates issues right there.

It would help if you told us more about this "plugin". It also sounds like it's crashing when it starts up; try opening cmd.exe and executing the batch file from there to see if you get any more information from the output.

EDIT: Oh, if the 'java' command isn't even recognized, you'll have to edit your system PATH environment variable to include the location of iava.exe on your system. Not something I've done in a long time, so try googling.

EDIT 2: NOW I remember you... Sorry, I'm on my iPhone and distracted. Everything I said still counts though!

'Soludra' on Achaea

Blog: http://jonathan.com/
GitHub: http://github.com/Twisol
[Go to top] top

Posted by Zirnitra   (8 posts)  [Biography] bio
Date Reply #2 on Wed 23 Dec 2009 08:58 PM (UTC)  quote  ]
Message
Hi again. This is the plugin: http://forums.lusternia.com/index.php?showtopic=8903

I followed the developer's instructions, so it should work. I don't know anything about Java though, hence the error.
[Go to top] top

Posted by Twisol   USA  (2,230 posts)  [Biography] bio
Date Reply #3 on Wed 23 Dec 2009 09:03 PM (UTC)  quote  ]
Message
Check my first edit, hehe. I'm distracted, so I had forgotten our previous interaction in the other thread, sorry!

'Soludra' on Achaea

Blog: http://jonathan.com/
GitHub: http://github.com/Twisol
[Go to top] top

Posted by Zirnitra   (8 posts)  [Biography] bio
Date Reply #4 on Wed 23 Dec 2009 09:18 PM (UTC)  quote  ]
Message
No problem! You were right, I added java to the variable and it works fine. Thanks again.
[Go to top] top

Posted by Twisol   USA  (2,230 posts)  [Biography] bio
Date Reply #5 on Wed 23 Dec 2009 09:19 PM (UTC)  quote  ]
Message
Great, glad I could help!

'Soludra' on Achaea

Blog: http://jonathan.com/
GitHub: http://github.com/Twisol
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


2,503 views.

[Reply to this subject]  Reply to this subject   [New subject]  Start a new subject   [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

[Home]

Written by Nick Gammon - 5K

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( http://www.gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Web site powered by FutureQuest.Net]